読者です 読者をやめる 読者になる 読者になる

Build and install Luakit on Ubuntu 10.04

依存するパッケージを入れる。

$ sudo aptitude install gperf help2man libwebkit-dev libgtk2.0-dev liblua5.1-0-dev

そのままだと、Luaのヘッダファイルを見つけられないので、config.mkをちょっといじる。

12c12
< PKGS := gtk+-2.0 gthread-2.0 webkit-1.0 lua
---
> PKGS := gtk+-2.0 gthread-2.0 webkit-1.0 lua5.1

あとは、ビルドとインストール。

$ make && sudo make install

おめでとう!!!!!